0
Planlagt

Exception in thread (console)

Ghostface 7 år siden opdateret af Paul Sinclair 7 år siden 1

Hi while coding on my own plugin I noticed messages like these popping up in the sublime console:


posting data for Python

message :+1 Python

icon base :--icon=/home/christoph/.config/sublime-text-3/Packages/codeivate-st/codeivated/icons/32x32/

Exception in thread Thread-30:

Traceback (most recent call last):

  File "X/threading.py", line 639, in _bootstrap_inner

  File "C:\Users\Paul\AppData\Roaming\Sublime Text 3\Packages\codeivate-st\codeivated\FeedBack.py", line 110, in run

NameError: global name 'Pref' is not defined


Maybe something to look into, let me know if you need more infos

Svar

Svar
Planlagt

Hi Ghostface, 


Thanks for reporting the bug. It looks like it is an issue with notify-send support that is only present on Linux when using Sublime Text 3.


I will fix this next time I do a Sublime 3 build.


As a temporary workaround in the Codeivate -> Settings - user  file, you can set 


"notify_send_active": false,


that should stop it from happening. This shouldn't cause any other issues with the plugin (apart from notify-send not working!).


Also in the same settings file you might want to set


"show_debug":false,


To hide alot of the other Codeivate output. This was accidentally left on in some initial versions of the plugin.



Cheers,

- Paul




Svar
Planlagt

Hi Ghostface, 


Thanks for reporting the bug. It looks like it is an issue with notify-send support that is only present on Linux when using Sublime Text 3.


I will fix this next time I do a Sublime 3 build.


As a temporary workaround in the Codeivate -> Settings - user  file, you can set 


"notify_send_active": false,


that should stop it from happening. This shouldn't cause any other issues with the plugin (apart from notify-send not working!).


Also in the same settings file you might want to set


"show_debug":false,


To hide alot of the other Codeivate output. This was accidentally left on in some initial versions of the plugin.



Cheers,

- Paul




Thanks a bunch for the quick response!

I did what you suggested and the messages are gone now.

Kundesupport af UserEcho