+1
Fixed

PhpStorm plugin startup error

Nicolas Hodin 6 years ago updated 6 years ago 4
Hello,

I tried to install the Codeivate plugin for PhpStorm, I have version 7.1.3 and at startup it shows a plugin error :

Plugin 'com.codeivate.plugin' failed to initialize and will be disabled. Please restart PhpStorm.


java.lang.ClassCastException: org.json.simple.JSONObject cannot be cast to org.json.simple.JSONArray
at com.codeivate.plugin.utils.UUIDUtils.getRandomName(UUIDUtils.java:105)
at com.codeivate.plugin.data.CodeivateSettings.<init>(CodeivateSettings.java:54)
at com.codeivate.plugin.data.CodeivateSettings.getInstance(CodeivateSettings.java:68)
at com.codeivate.plugin.keyhandlers.CodeivateKeyHandler.<init>(CodeivateKeyHandler.java:67)
at com.codeivate.plugin.keyhandlers.CodeivateKeyHandler.getInstance(CodeivateKeyHandler.java:55)
at com.codeivate.plugin.keyhandlers.CodeivateTypedActionHandler.<init>(CodeivateTypedActionHandler.java:37)
at com.codeivate.plugin.CodeivateApplicationPlugin.initComponent(CodeivateApplicationPlugin.java:111)
at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentConfigComponentAdapter$1.getComponentInstance(ComponentManagerImpl.java:548)
at com.intellij.openapi.components.impl.ComponentManagerImpl$ComponentConfigComponentAdapter.getComponentInstance(ComponentManagerImpl.java:590)
at com.intellij.util.pico.DefaultPicoContainer.getLocalInstance(DefaultPicoContainer.java:225)
at com.intellij.util.pico.DefaultPicoContainer.getInstance(DefaultPicoContainer.java:212)
at com.intellij.util.pico.DefaultPicoContainer.getComponentInstance(DefaultPicoContainer.java:199)
at org.picocontainer.alternatives.AbstractDelegatingMutablePicoContainer.getComponentInstance(AbstractDelegatingMutablePicoContainer.java:75)
at com.intellij.openapi.components.impl.ComponentManagerImpl.createComponent(ComponentManagerImpl.java:121)
at com.intellij.openapi.application.impl.ApplicationImpl.createComponent(ApplicationImpl.java:372)
at com.intellij.openapi.components.impl.ComponentManagerImpl.a(ComponentManagerImpl.java:112)
at com.intellij.openapi.components.impl.ComponentManagerImpl.init(ComponentManagerImpl.java:89)
at com.intellij.openapi.components.impl.stores.ApplicationStoreImpl.load(ApplicationStoreImpl.java:87)
at com.intellij.openapi.application.impl.ApplicationImpl.load(ApplicationImpl.java:509)
at com.intellij.idea.IdeaApplication.run(IdeaApplication.java:150)
at com.intellij.idea.MainImpl$1$1$1.run(MainImpl.java:59)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
at java.awt.EventQueue.access$200(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:694)
at java.awt.EventQueue$3.run(EventQueue.java:692)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
at com.intellij.ide.IdeEventQueue.e(IdeEventQueue.java:697)
at com.intellij.ide.IdeEventQueue._dispatchEvent(IdeEventQueue.java:524)
at com.intellij.ide.IdeEventQueue.dispatchEvent(IdeEventQueue.java:335)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)

Any idea? 

Thanks a lot & best regards

Answer

Answer
Started
I am investigating
Answer
Started
I am investigating
+2
Hi Nicolas,
Thanks for raising this! It was a problem with the third party random machine name generator that the plugin uses. This has been fixed in version 0.2.3 Which is available if you update the plugin or you can download it from http://plugins.jetbrains.com/plugin/7416

Cheers, 
Paul
Hi,
It works fine, i updated it and no error message at startup.
Thanks a lot for the quick fix!

Best regards,
Nicolas